
 
 
 
 

 
 

 

 

Introducing New & Updated 
Features in Marvelous Designer 4 

 



Quadrangulate (New in MD4) 

 

Objective  

To transform the synchronized triangular mesh to quad mesh (quadrangulate the mesh structure).  

Location 

 Main Menu → 3D Garment → Pattern → Quadrangulate 

    

 Right Click on Pattern at the 3D Garment window → Pattern → Quadrangulate 

   

 Property Editor (Pattern) → Misc. → Mesh Type → Quad 



※ The reason why there are some residual triangles in Quad is because we are abiding with a rule 

of aligning quad mesh in the areas of higher significance in terms of fabric flow. Quadrangulate 
feature in Marvelous Designer was developed to align Quads with the boundary direction in the 
simulating mode. The side effect is that there will be some residual triangles.  

After in depth research based on user feedback up till now, despite some residual triangles, we 
decided that abiding to the rule will help users more in terms of workflow.  
 
It is our goal to improve this Quadrangulate feature and we promise to keep developing what's best 

for our users. ※ 

 



Basting (New in MD4) 

 

Tack  

 

 

Objective 

To see the change in fit by temporarily clipping two points of the garment 

Location 

 3D Garment Window Toolbar →  Tack 

Operation 

1. Select the tool according to the Location above 
    



2. Click on the starting clipping point on draped garment. 
→ Starting point will be created accompanied by a connecting line.  

   

3. Click on the end clipping point. 
→ End point and the connecting line will be created. 

→ Same Tack will also be created in the 2D Pattern Window.  

  
   

4. Click on  Simulate icon. 

→ The garment will be draped and the two points created will stick together closely.  

 



Tack on Avatar  

 

 

Objective 

To temporarily fix one point on the garment to the avatar.  

Location 

 3D Garment Window Toolbar →  Tack on Avatar 

Operation 

1. Select the tool according to the Location above. 
   

2. Click on the point of the 3D garment that will be fixed to the avatar.  

→ A point is created and the connecting line will accompany. The selected garment will become 

semi-transparent 
   

3. Click on the point of the avatar 

→ 3D garment will become semi-transparent. 



→ Same Tack will also be created in the corresponding 2D Pattern. 

  

4. Click on  Simulate icon. 

→ The garment will be draped and the point on the garment and the point on the avatar will 

stick together closely.  

 



Delete  

Objective 

To delete the Tack created.  

   

Location 

 3D Garment Window Toolbar →  Edit Basting 

Operation 

1. Select the tool according to the Location above. 
   

2. Click on the Tack that is to be deleted. 
→ It will be highlighted in yellow. 

   
3. Press the Delete key on keyboard or right-click the mouse and select Delete. 

→ The corresponding Tack is deleted. 

※  Ctrl + A will select all Tacks created. ※ 

 

 



Symmetric Design (New in MD4) 
Users can design or edit patterns symmetrically  

 

Symmetric Paste  

 
Objective 

To let users design and edit symmetrically 

Location 

 Right-click on Pattern or 2D Pattern Window → Symmetric Paste 

Operation 

1. Select and Copy the pattern 
   

2. Select the tool according to the Location above 

→ The copied pattern will follow the cursor. 

   
3. Click on the preferred pattern location for Symmetric Paste. 

→ Connecting line will be created between the selected pattern and Symmetrically Pasted pattern. 



Symmetric Editing 

 
Symmetric Editing can only be used on Symmetrically Pasted pattern.  

Symmetric Editing is possible with all edits related to Internal Polygon/Line, Move/Rotate 
Point/Line, Editing Size of the Pattern, Curve (Edit Curvature, Curve Point), Add Point, Internal Polygon – 
Convert to Hole, Flip Horizontally/Vertically, Unfold pattern. It also reflects all Properties including Elastic 
and Fold Angle, etc. 

It does not reflect Items such as Fabric, Button 

http://192.168.0.2:8090/pages/viewpage.action?pageId=20349272


Remove Symmetric 

Objective 

To deactivate the Symmetry feature of the two selected patterns. 

Location 

 Right-click on the Symmetric Paste pattern → Remove Symmetry 

Operation 

1. Select the tool according to the Location above 
→ Symmetry function is deactivated. 

 

 



Symmetric Merge  

 
Objective 

Symmetric Merge feature allows the selected two patterns for Symmetric Design to merge 

Location 

 Right-click on segment → Symmetric Merge   

Operation 

1. Click on the segment of the Symmetric pattern and proceed as shown above in Location. 
→ Two Symmetric patterns are merged to become one pattern and the Symmetric feature is 

removed. 

※ Merge is not possible for segments with points or curves ※ 



Sewing 
 

1:N Segment Sewing (Updated in MD4) 

Objective 

To easily and quickly sew multiple segments onto one segment proportionally. 
When sewing a segment onto N segments, which are different lengths, a segment is split into a number 
of N segments automatically corresponding to the ratio of N segments’ lengths.   

Location 

 Main Menu → Sewing → Segment Sewing (Segment Sewing / N) 

 2D Pattern Window Toolbar → (Segment Sewing) 

Operation 

1. Select the tool according to the Location above 
  

2. Click on a segment. 
   

3. Hold down the Shift key. 
→ The segment will be highlighted. 

   
4. Holding down the Shift key, hover the mouse to the other segment, which will be paired.   

   
5. Move the mouse along the segment to change the Notch direction.  

   
6. Click on the segment to complete sewing. 

→Sewing line lengths are shown in blue by the cursor (each sewing line length, N segment 

length difference, total length of segments)  

※ If there is a difference between the sewing line lengths of over 1 inch, the sewing line will be 

shown in red to alert the user. ※ 

7. Holding down the Shift key, repeat steps 4, 5 and 6. 
   

8. Release the Shift key if all sewing lines are paired with the first sewing line. 

→ The sewing line color changes from fluorescent to each color and completes 1:N Segment 

Sewing.  



 

※ Whilst setting the N sewing lines, you can revert back to the previous step when you press 

‘Delete’ or cancel all steps by pressing ‘Esc’. ※ 



Free Sewing (Updated in MD4) 

Objective 

To sew the designated area regardless of the pattern or internal polygon/line 

  

Location 

 Main Menu → Sewing → Free Sewing / M 

 2D Pattern Window Toolbar → (Free Sewing) 

  

Operation 

1. Select the tool according to the Location above 
   

2. Click on a point along the line of pattern to indicate the starting point and the end point. 
     

3. Click on the starting point on the other segment that you want to sew. 

→ There will be a guiding point that corresponds to the same length of the first segment. 

→ Sewing line lengths are shown in blue by the cursor  (difference between the first and the 

other segment / length of the first segment / length of the other segment)   

※ If there is a difference between the sewing line lengths of over 1 inch, the sewing line will be 
shown in red to alert the user. ※ 

4. Hover the mouse towards the guiding point and it will snap.  
  

5. Click on the guiding point to sew at the same sewing line length.  

 

※ The Notch depends on the starting point and end point of the sewing. ※ 



 

※ Right-click on the sewing line to type in the accurate length by typing. ※ 

 

 



1:N Free Sewing (New in MD4) 

 

Objective 

1:N Free Sewing tool is used to sew a specific area of a segment not like Segment Sewing tool. 

Location 

 Main Menu → Sewing → Free Sewing / M 

 2D Pattern Window Toolbar → (Free Sewing/M) 

Operation 

1. Select the tool according to the Location above. 
  



2. Click on a point along the line of pattern to indicate the starting point and the end point. 
   

3. Hold down the Shift key. 

→ The segment will be highlighted. 

   
4. Holding down the Shift key, click on the starting point and the end point of the other N segment  

→ Sewing line lengths are shown in blue by the cursor  (difference between the first and the 

other segment / length of the first sewing line / length of the other N sewing line)   
※  If there is a difference between the segment lengths of over 1 inch, the sewing line will be 

shown in red to alert the user. ※ 

5. Holding the Shift key, repeat step 4. 
 

6. Release Shift key after all necessary sewing line are paired with. 

→ The sewing line color changes from fluorescent to each color and completes 1:N Segment 

Sewing.  
※ If you select inappropriate segment, the sewing line turns to red and can’t be sewn ※ 

 



Transform Pattern (Updated in MD4) 

 

Pattern Scale 

Objective 

To scale patterns. 
 

※ If the patterns are laid in a way that it is difficult to select the area within the pattern 

with Edit Pattern tool, use Transform Pattern tool. ※ 

 

Location    

 Main Menu → 2D Pattern → Edit → Transform Pattern / A 

 2D Pattern Window Toolbar →  Transform Pattern 



Operation 

1. Select the tool according to the Location above 

   
2. Click on the pattern > Drag and designate the patterns to be rescaled. 

→ You will see the Scale guide points on the corners of the pattern and Pivot point in the middle 

of the pattern. 
   

3. Click on one of the Scale guide points > Drag to rescale proportionally. 

 
      

4. Click on the Pivot point to rescale the pattern with the reference point as middle. 
→ Pivot point is activated and turns into orange.  

 



5. Use the Scale guide points to rescale the pattern. 
→ The pattern is rescaled proportionally to the Pivot point. 

 

※ Click on the Pivot > Drag to set the reference point to rescale the pattern ※ 

 

 

 



Copy Pattern (Updated in MD4)  

Objective  

Users can copy/paste patterns 

Location 

 Main Menu → Edit → Copy / Paste 

 Right-click on pattern → Copy (Ctrl + C) / Paste (Ctrl + V) 

Operation 

1. Select the tool according to the Location above 
→ The copied pattern will follow the mouse cursor. 

   
2. Click on the preferred location of the 2D Pattern Window to place the pattern. 

→ The pattern will be automatically numbered in the Scene tab under Object Browser to avoid 

duplication.  

※ Hold down Shift key to paste patterns horizontally/vertically/45˚ ※ 

※ If the patterns are already draped in 3D, copied patterns are also reflected in the 3D Garment 

Window ※ 

 



Object Browser (Updated in MD4) 

Object Browser is made up of four tabs: Scene, Fabric, Arrangement Point and Arrangement Bounding 
Volume (A-BV). It allows you to view all components of objects.  

You can view or hide 'Object Browser' via Main Menu → Display → Windows → Object Browser 

SCENE 

Scene tab is the primary, fastest, and most streamlined tool for finding or selecting object. 
It lets you quickly review a list of all objects and its structure in the 3D Garment and 2D 
Pattern Window. 

The list is in the order of object created, but when you click on Name, the object list is 
sorted A to Z (1 to 10). Once you click again, the list is reordered and sorted Z to A (10 to 
1). (Updated in MD4) 

FABRIC Fabric Tab represents the menu for Fabric. Users can select, add, copy and reset Fabric. 

A-POINT 
A-POINT box is a tool for displaying an Arrangement Point. It lets you select, add or delete 
the Arrangement Points. Also you can save or open the custom setting of Arrangement 
Point. 

A-BV 
A-BV tab is a tool for displaying an Arrangement Bounding Volume. It lets you add, fit and 
delete the Arrangement BV. You also can save and open the custom setting of 
Arrangement BV. 

 
 

 
 



Normal Flipping (New in MD4) 

 

Objective 

To easily change pattern normal in the draped or undraped status 

After the patterns are sewed, you can minimize time by Normal Flipping at the last step.  

Location 

 Main Menu → 3D Garment → Pattern → Flip Normal 

 Right-click on 3D Garment → Pattern → Flip Normal 

Operation  

1. 3D Garment Window Toolbar  Click on  Move Pattern 
2. Select Pattern for Normal Flipping. 

   
3. Select the tool according to the Location above 

→ The Normal of fabric is changed. 



Box Selecting (Updated in MD4) 

Objective  

To select designated area in the form of box shape.  

Location 

 Main Menu → 3D Garment → Mesh → Box Select  

 3D Garment Window Toolbar →  (Left-click for more than 2 seconds) → Box Selecting 

Tool 

Operation 

1. Select the tool according to the Location above 
→ The patterns area is shown in green meshes in the 3D Garment and 2D Pattern Windows. 

※  Show Garment and Textured Surface icons will be deactivated when the Box Selecting tool is 

activated. ※ 

2. Click on the specific area on the garment > Drag to select the box area. 
→ Selected area is shown in green meshes 

→ Selected area is also reflected in the 2D Pattern Window. 

   
3. Drag and move and select the area once again to use the Gizmo to fix at the preferred location.  

 



※ Selecting specific sewing line 

Double click on the pattern outline to select the specific sewing line. This feature is limited to the outline 

of a single pattern only, i.e. if the outline is connected over several patterns, the selection feature will not 
work.  
 
The selected area is limited to less than 20˚ difference between the line connecting the starting point and 
the end point.  

 



※ Selecting pattern 

Double click the pattern vertex to select the pattern on the 3D Garment Window or the 2D Pattern 
Window.  

 

Selecting with holding down the Shift + Ctrl on keyboard, the selected area is added, whilst holding 
down the Ctrl on keyboard will de-select the area. 

 

 
 



Box Pinning (Updated in MD4) 

Objective  

To fix the garment via creating pin in a box form.  

  

Location 

 Main Menu → Pin → Box Pinning  

 3D Garment Window Toolbar →  (Left click for more than 2 seconds) → Box Pinning Tool 

  

Operation 

1. Select the tool according to the Location above 
→ The patterns area is shown in red meshes in the 3D Garment and 2D Pattern Windows. 

※  Show Garment and Textured Surface icons will be deactivated when the Box Pinning tool is 

activated. ※  

2. Click on the specific area on the garment > Drag to select the box area. 
→ Selected area is shown in red meshes under the Vertex. 

→ Selected area is also reflected in the 2D Pattern Window. 

   
3. Drag and move and select the area once again to use the Gizmo to fix at the preferred location. 

 

※  If it is difficult to create pin precisely on the 3D Garment Window, you can do this easily in the 2D 

Pattern Window. ※ 



※ Create Pin for sewing line 

Pin for specific sewing line is created when you double click the pattern outline in the 3D Garment or 2D 
Pattern Windows. This feature is limited to the outline of a single pattern only, i.e. if the outline is 
connected over several patterns, the selection feature will not work. 

The selected area is limited to less than 20˚ difference between the line connecting the starting point and 
the end point.  

 

  



※Create Pin for pattern 

Pin for specific pattern is created when you double click on the pattern Vertex  

 

 Selecting with holding down the Shift + Ctrl on keyboard, the selected area is added, whilst holding 
down the Ctrl on keyboard will de-select the area. 



Arranging Patterns (Updated in MD4) 

Objective 

To view Arrangement Points and place pattern around the avatar with Arrangement Points. 

Location 

 Main Menu → Display → Avatar → Show Arrangement Point / Shift + F 

 Hover mouse over Avatar icon → (Show Arrangement Point) 

Operation 

1. Select the tool according to the Location above. 
→ Then, the Arrangement Points will appear around the avatar. 

     
2. Select the pattern and select the arrangement point around the avatar. 

→ The center of the pattern is arranged to the corresponding Arrangement Points. 

 



※ Arrangement Point is placed in spiral form. 

If the length of the pattern is longer than the Bounding Volume then the pattern is arranged in spiral 
form.  

Ex) Case for arranging the Cuffs pattern using the wrist Arrangement Point of the avatar 

  → Usually for Cuffs, the right side goes over the left side  

 

Case for arranging front and back patterns of a blouse on a woman avatar 

→ Usually for womenswear, the right side pattern goes over the left side pattern (Opposite for 

menswear) 

 

※ You can control the precise location with Gizmo or Property Editor even after the patterns are 

arranged along the Arrangement Points. ※ 



Flip Wrap Direction (New in MD4) 

 

Objective 

To flip Wrap Direction of the arranged patterns. 

Location   

 Right-click on pattern → Flip Wrap Direction 

Operation 

1. Select the pattern in the 3D Garment Window. 

2. Select the tool according to the Location above. 
→ The Wrap Direction is flipped. 



Pattern Order (New in MD4) 

 

Objective 

When creating patterns in the 2D Pattern Window, the last pattern created is arranged at the front by 
default. Users can rearrange the pattern order freely. 

Location 

 Bring to Front : Right-click on pattern → Bring To Front → Bring Forward / Bring To Front 

 Send to Back : Right-click on pattern → Send To Back → Send Backward / Send To Back 

Operation 

1. Select the pattern for designating layer. 

2. Select the tool according to the Location above 

→ Layer order is changed as set by the user. 



Layer Clone (New in MD4) 

 

Objective 

Pattern layer is cloned, sewing lines and internal lines are sewed together whilst the garment is draped in 
the 3D Garment Window.  

This feature is extremely useful in creating garments that has layers such as Padded effect, Collars, Cuffs. 

Location 

 Main Menu → 2D Pattern → Edit → Layer Clone 

    

 Right-click on pattern → Layer Clone (Ctrl + Shift + V) 

  



Operation 

1. Select the pattern for layer cloning. 

   
2. Select the tool according to the Location above  

3. (Sync) Click on the Sync icon to reflect this in the 3D Garment Window.  

 



FBX Import (New in MD4) 

FBX Import feature works for Mesh and Skeletal at this moment, due to integration issues, it is currently 
unavailable for Material, Animation and Morph features.    
 
New Updates 
 

 Ability to import “Initial Static Mesh” or “Skeletal Mesh”  
 Automatic preset for Y & Z up 
 Auto Scale 

 
Future Updates 
 

 Import Animation Data (to be updated during Open Beta period) 

 Import Morph Data (to be updated during Open Beta period) 
 Import “Multiple Static Mesh” or “Multiple Skeletal Mesh” 
 Loading Information Dialog (to be updated during Open Beta period) 
 Import Camera Animation or Camera Node 

 
Currently also working on…  
 

 Compatibility issue of 3D software such as DAZ 
 We confirm that FBX format from DAZ would not be loaded in other 3D Software tools properly, 

and we will fix this issue as soon as possible. 
 


